FF Logo
Hello Guest | Login | Register
Latest reviews
· DM - Cryptic 
Reviewed by Oddball

· DM - Abrupt Decay (RC1) 
Reviewed by Cupid

· DM - Wulf Hunt 
Reviewed by Oddball

· DM - Nuketown2050 
Reviewed by Oddball

· Mod Manager Re-Mars-tered 
Reviewed by nme

· DM - Blunder's Villa 
Reviewed by shark5678

· DM - Blunder's Villa 
Reviewed by Oddball

· DM - How Fast Can You Run? 
Reviewed by Goober

· Play Faction 
Reviewed by nick

· DM - Chapel 
Reviewed by shark5678

· DM - Rail Depot 
Reviewed by Oddball

· DM - Waterlogged (ps2) 
Reviewed by shark5678

· Homer Simpson Hendrix 
Reviewed by Endoran

· RFA First Person Mod 
Reviewed by Cyrus

· Singularity Explosives v0.8... 
Reviewed by nme

Who's online?
0 users and 60 guests
Pages: [1]
Users Avatar
Lazarus
Posts: 12
Joined: July 18, 2016, 1:36

0
(Y)

Posted: July 18, 2016, 2:01 Post #1
Greetings All:

I just installed Red Faction ( original retail version ) on my system and "updated" the game with the Pure Faction 3.0d patch. The game ran fine, so I decided to try a bit of modding, which is where the issues started. I followed the instructions in Goober's Red Faction 1 - Basic Mod Creation tutorial here:

https://www.youtube.com/watch?v=CVlHe7MaITs&feature=youtu.be

However, when I attempt to load the game with my mod, it crashes to desktop and gives me the following error message:

Problem signature:
Problem Event Name: APPCRASH
Application Name: PF.exe
Application Version: 0.0.0.0
Application Timestamp: 3c0f9b78
Fault Module Name: StackHash_64bb
Fault Module Version: 0.0.0.0
Fault Module Timestamp: 00000000
Exception Code: c0000005
Exception Offset: ffffffff
OS Version: 6.1.7601.2.1.0.256.48
Locale ID: 1033
Additional Information 1: 64bb
Additional Information 2: 64bbaeb568960ffaf9fcf49e465c0399
Additional Information 3: caf2
Additional Information 4: caf2315e472954357b78aa224437df9e

My mod only contains 4 table files ( entity.tbl, game.tbl, items.tbl, weapons.tbl ). The changes I've made in the aforementioned files are quite minor ( e.g., editing max clip capacity, etc.). I used VPPBuilder32 v1.0 to compile the modified table files into a .vpp, which I labled CustomWeapons_tables.vpp. This .vpp file is installed in:

C:\Games\RedFaction\mods\CustomWeapons

I'm hoping that someone can make sense of the aforementioned error message. Here are my system's specs, in case it's relevant:

OS: Windows 7 Professional 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_ldr.160408-2045)

CPU: Intel i7-4770K CPU ~3.5GHz

RAM: 32 MB

GPU: EVGA GeForce GTX 770 ( 4 GB )

Monitor: BenQ XL2411Z ( 1920 x 1080 native resolution )

Any assistance would be greatly appreciated. Thanks in advance!

Users Avatar
Goober
Posts: 272
Joined: September 11, 2009, 19:58

0
(Y)

Posted: July 18, 2016, 22:36 Post #2
My initial thought is the syntax of one of the .tbl files might be a little messed up. Table files are very picky, and any syntax problems at all will usually cause a crash.

Can you provide your edited files to me? I can go through them and see if I can find what's causing the issue.

Users Avatar
Lazarus
Posts: 12
Joined: July 18, 2016, 1:36

0
(Y)

Posted: July 19, 2016, 4:39 Post #3
Quoting Goober
My initial thought is the syntax of one of the .tbl files might be a little messed up. Table files are very picky, and any syntax problems at all will usually cause a crash.

Can you provide your edited files to me? I can go through them and see if I can find what's causing the issue.


Hey Goober:

Thanks for your reply. I've provided links to my edited .tbl files below, per your suggestion. However, I think I may have isolated the problem; line 1394 of the weapons.tbl file:

$Clip Size: 1 1 ( if set to 2 2 game crashes ) ( if set to 3 3 or > no issues )

For some inexplicable reason the game won't allow me to set the clip size of the Rail Gun to 2, but it will permit clip sizes of 3 +. Once I set the value to something other than 2, the game stopped crashing. Do you know why this is the case?

Two other things I'm trying to do are locate the .tga file that controls the ammo counter for the Assault Rifle ( it's not in the ui.vpp ), and figure out how to increase Parker's running/sprint speed. Any suggestions. Many thanks for your assistance!

https://www.dropbox.com/s/cfexkecibamrnrh/weapons.tbl?dl=0
https://www.dropbox.com/s/b0t8d86a0glq0e4/hud.tbl?dl=0
https://www.dropbox.com/s/wnvyc1i9r7rydqu/items.tbl?dl=0
https://www.dropbox.com/s/k8ttcoypo8qxo38/game.tbl?dl=0
https://www.dropbox.com/s/ya5z6rwf1ad7bva/entity.tbl?dl=0

Users Avatar
Goober
Posts: 272
Joined: September 11, 2009, 19:58

0
(Y)

Posted: July 19, 2016, 19:10 Post #4
Quoting Lazarus
Two other things I'm trying to do are locate the .tga file that controls the ammo counter for the Assault Rifle ( it's not in the ui.vpp ), and figure out how to increase Parker's running/sprint speed. Any suggestions. Many thanks for your assistance!


I haven't had a chance to look into the weapons.tbl issue for you, but I'll address this now.

I'm pretty sure the AR ammo counter is fully hard-coded, and not realistically editable.

As for increasing running speed, is this a multiplayer mod or single player? Running speed in multiplayer is hard-coded, and again isn't realistically editable. Single player run speed though is controlled as far as I recall by the following values in the "miner1" section of entity.tbl (this section begins at line 663):

$Max Vel: 6.0
+slow factor: 0.5
+fast factor: 1.5
$Acceleration: 20.0

Users Avatar
Lazarus
Posts: 12
Joined: July 18, 2016, 1:36

0
(Y)

Posted: July 19, 2016, 21:25 Post #5
Quoting Goober
I haven't had a chance to look into the weapons.tbl issue for you, but I'll address this now.

I'm pretty sure the AR ammo counter is fully hard-coded, and not realistically editable.


That's a bummer, all I wanted to do was change the color of the AR ammo counter's font ( from red to blue ). Oh well...:P


Users Avatar
Lazarus
Posts: 12
Joined: July 18, 2016, 1:36

0
(Y)

Posted: July 20, 2016, 3:48 Post #6
Quoting Goober
As for increasing running speed, is this a multiplayer mod or single player? Running speed in multiplayer is hard-coded, and again isn't realistically editable. Single player run speed though is controlled as far as I recall by the following values in the "miner1" section of entity.tbl (this section begins at line 663):

$Max Vel: 6.0
+slow factor: 0.5
+fast factor: 1.5
$Acceleration: 20.0


Got it. However, changing the "Max Velocity" also seems to affect Parker's climbing speed. Is there a separate entry for climbing speeds only? BTW, all my changes are single player only. Please let me know if you found any syntax errors in the .tbl files I uploaded. Thanks again for all your assistance!

Users Avatar
Goober
Posts: 272
Joined: September 11, 2009, 19:58

0
(Y)

Posted: July 20, 2016, 20:09 Post #7
Quoting Lazarus
I think I may have isolated the problem; line 1394 of the weapons.tbl file:

$Clip Size: 1 1 ( if set to 2 2 game crashes ) ( if set to 3 3 or > no issues )

For some inexplicable reason the game won't allow me to set the clip size of the Rail Gun to 2, but it will permit clip sizes of 3 +. Once I set the value to something other than 2, the game stopped crashing. Do you know why this is the case?


I replicated this change, and was not able to trigger a crash. Also, I was able to load the .tbl files you provided without a crash.

At what point does your game crash?

Users Avatar
Lazarus
Posts: 12
Joined: July 18, 2016, 1:36

0
(Y)

Posted: July 20, 2016, 23:30 Post #8
Quoting Goober
Quoting Lazarus
I think I may have isolated the problem; line 1394 of the weapons.tbl file:

$Clip Size: 1 1 ( if set to 2 2 game crashes ) ( if set to 3 3 or > no issues)


I replicated this change, and was not able to trigger a crash. Also, I was able to load the .tbl files you provided without a crash.

At what point does your game crash?

It crashes immediately upon attempting to load a saved game ( or start a new one ) from the main menu. Interesting, because I just tried the setting the clip size to 2 2, and it promptly crashed again. Set it back to 1 1, 3 3, or any other value, no problem. Here's the error message again:

Problem signature:
Problem Event Name: APPCRASH
Application Name: PF.exe
Application Version: 0.0.0.0
Application Timestamp: 3c0f9b78
Fault Module Name: StackHash_64bb
Fault Module Version: 0.0.0.0
Fault Module Timestamp: 00000000
Exception Code: c0000005
Exception Offset: ffffffff
OS Version: 6.1.7601.2.1.0.256.48
Locale ID: 1033
Additional Information 1: 64bb
Additional Information 2: 64bbaeb568960ffaf9fcf49e465c0399
Additional Information 3: caf2
Additional Information 4: caf2315e472954357b78aa224437df9e

Users Avatar
Goober
Posts: 272
Joined: September 11, 2009, 19:58

0
(Y)

Posted: July 23, 2016, 15:17 Post #9
The game isn't crashing for me at that point with the tables you linked.

Try making a new test mod with just those tables, and see if it still crashes.

Pages: [1]

© 2009-2019 Faction Files

Page generated in 0.024 seconds